package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[?&\/]x=([^&\n]*)`)
var str = `/abc/x=1+2&y=25&c=1
x=1+2&y=25&c=1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}