import Foundation
let pattern = #"(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"this"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)