# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$/$1;$2;$3\n/gX;t' <<< "1 foo 745
2 baz 746
garbage"