using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)\s([a-z]+)\s(\d+)\s+|[\S\s]+$";
string substitution = @"$1;$2;$3\n";
string input = @"1 foo 745
2 baz 746
garbage";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}