use strict;
my $str = '_record_number record_id id_testing Notes IntakeComplete
111 6 5 " We will not be testing because of covid 19" 1
222 6 5 " We will not be "testing because of covid 19" 1
333 6 5 " We will not be "testing" because of covid 19" 1';
my $regex = qr/(?<=")\t+(?=.+")/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";