#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\!\[.+?\]\((.+?)\)"
Local $sString = "" & @CRLF & _
""
Local $sSubst = "<img src="$1" width="300">"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)