use strict;
my $str = '
';
my $regex = qr/\!\[.+?\]\((.+?)\)/mp;
my $subst = '<img src="$1" width="300">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";