re = /\!\[.+?\]\((.+?)\)/m
str = '
'
subst = '<img src="$1" width="300">'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result