// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\!\[.+?\]\((.+?)\)").unwrap();
let string = "
";
let substitution = "<img src=\"$1\" width=\"300\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}