package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:<[^\s].*?>\n?.*\n?<\/.*?>|<[^\s].*?[^\s][" ]{0,1}\/>)`)
var str = `Hi :wave:,
this is html in like <div> HTML tag </div>
and this below hypertext is span with tags
<div>
text <b><i></i></b>
</div>
<script>
console.log('hi');
</script>
<span id="text"> Hi <b>you</b> </span>
<id></id>
<br />
<br />
<br/>
<img src="./here.jpg" />
<input text="text"/>`
var substitution = "{{1}}"
fmt.Println(re.ReplaceAllString(str, substitution))
}