re = /(?:<[^\s].*?>\n?.*\n?<\/.*?>|<[^\s].*?[^\s][" ]{0,1}\/>)/mi
str = 'Hi :wave:,
this is html in like <div> HTML tag </div>
and this below hypertext is span with tags
<div>
text <b><i></i></b>
</div>
<script>
console.log(\'hi\');
</script>
<span id="text"> Hi <b>you</b> </span>
<id></id>
<br />
<br />
<br/>
<img src="./here.jpg" />
<input text="text"/>'
subst = '{{1}}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result