using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(abcd|bcde|cdef|defg|efgh|fghi|ghij|hijk|ijkl|jklm|klmn|lmno|mnop|nopq|opqr|pqrs|qrst|rstu|stuv|tuvw|uvwx|vwxy|wxyz)+";
string input = @"aaaa
abcd
wxyz
uvwx
rupak
axway
single characters
rupak abcd test
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}