$re = '/\(([^(]+)\)/m';
$str = '[(\'1\',\'Hello is 1)people 2)animals\'), (\'People are 1) hello 2) animals\'), (\'a\')]';
$subst = "[\1]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;