// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(([^(]+)\)").unwrap();
let string = "[('1','Hello is 1)people 2)animals'), ('People are 1) hello 2) animals'), ('a')]";
let substitution = "[\\1]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}