package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:ts(?:m(?:09|1[0-9]|20))?|edtd\-ts)\.eset\.com$`)
var str = `tsm09.eset.com
tsm10.eset.com
tsm11.eset.com
tsm12.eset.com
tsm13.eset.com
tsm14.eset.com
tsm15.eset.com
tsm16.eset.com
tsm17.eset.com
tsm18.eset.com
tsm19.eset.com
tsm20.eset.com
ts.eset.com
edtd-ts.eset.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}