re = /(['"])(?:(?!\1|\\).|\\.)*\1/x
str = 'Hello Colm "This is a test\\\\\\\\"
"This is also an NL test"
\'And this has an escaped quote don\\\'t in it \' Blue Boy
"This has a single quote \' but doesn\\\' end the quote as it started with double quotes"
"line spanning with escaped quote at the end of a line\\"
"
"Foo Bar" "Another Value" something else'
subst = 'Subbed'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result