#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<([a-z]+@[a-z]+(\.[a-z]{2,3}){1,2})>"
Local $sString = ""Meu nome <meuNome@email.com.br>";" & @CRLF & _
"" & @CRLF & _
""Meu nome <meuNome@email.com>";" & @CRLF & _
"" & @CRLF & _
""Meu nome <a@b.com.br>";" & @CRLF & _
"" & @CRLF & _
""Meu nome <teste de conteudo>";" & @CRLF & _
"" & @CRLF & _
""Meu nome <testede@conteudo>";" & @CRLF & _
"" & @CRLF & _
""Meu nome <var1>var2>";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")