// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<([a-z]+@[a-z]+(\.[a-z]{2,3}){1,2})>").unwrap();
let string = "\"Meu nome <meuNome@email.com.br>\";
\"Meu nome <meuNome@email.com>\";
\"Meu nome <a@b.com.br>\";
\"Meu nome <teste de conteudo>\";
\"Meu nome <testede@conteudo>\";
\"Meu nome <var1>var2>\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}