$re = '/<(.*)>/';
$str = '"Meu nome <meuNome@email.com.br>";
"Meu nome <meuNome@email.com>";
"Meu nome <a@b.com.br>";
"Meu nome <teste de conteudo>";
"Meu nome <testede@conteudo>";
"Meu nome <var1>var2>";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);