re = /(.*?)=(.*?)(?:;(?: |)|$)/m
str = 'roses=red;violets=blue;regex=cool;andsoare=you;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end