$re = '/^[0-9]+(?:(?:\.[0-9]{1,2})?[km]?|\.)$/m';
$str = '400k
400.2k
4m
500.
500000
4.2.k
.3k
4...k
300.k';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);