#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[\[(?:(?!\[\[|]]).)*\]\]|\b(FOO)\b"
Local $sString = "lorem ipsum FOO dolor" & @CRLF & _
"Should NOT match : lorem ipsum [[FOO]] dolor ==> OK" & @CRLF & _
"Should NOT match : lorem [[ipsum FOO dolor]] sit amet ==> Not OK" & @CRLF & _
"Should NOT match : lorem [[ipsumFOOsolor]] sit amet ==> OK" & @CRLF & _
"Should NOT match : [[lorem]] [[ipsum-FOO&dolor-sit.pdf#page=130]] ==> Not OK" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")