using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[(?:(?!\[\[|]]).)*\]\]|\b(FOO)\b";
string input = @"lorem ipsum FOO dolor
Should NOT match : lorem ipsum [[FOO]] dolor ==> OK
Should NOT match : lorem [[ipsum FOO dolor]] sit amet ==> Not OK
Should NOT match : lorem [[ipsumFOOsolor]] sit amet ==> OK
Should NOT match : [[lorem]] [[ipsum-FOO&dolor-sit.pdf#page=130]] ==> Not OK
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}