re = /\[\[(?:(?!\[\[|]]).)*\]\]|\b(FOO)\b/m
str = 'lorem ipsum FOO dolor
Should NOT match : lorem ipsum [[FOO]] dolor ==> OK
Should NOT match : lorem [[ipsum FOO dolor]] sit amet ==> Not OK
Should NOT match : lorem [[ipsumFOOsolor]] sit amet ==> OK
Should NOT match : [[lorem]] [[ipsum-FOO&dolor-sit.pdf#page=130]] ==> Not OK
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end