using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*;(.*);.*$";
string input = @"220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad
220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad
221;Paul;30;23/11/2008;22/12/2008;He is a Software engineer at MNC;Bangalore
222;Emma;23/11/2008;22/12/200825;Working as a mechanical enginner;Chennai
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}