re = /\/#\s*((?:.|\n)*?)\s*#\//m
str = 'Hello
/# my name
is
Mike
nice to meet you
#/
aoeuoaeu /#
multi-line
#/
/# single-line #/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end