# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^1{1}(3{1}\d{1}|5{1}[012356789]{1}|8{1}[035689]{1})\d{8}$//gm;t' <<< "15011020699"