$re = '/^1{1}(3{1}\d{1}|5{1}[012356789]{1}|8{1}[035689]{1})\d{8}$/m';
$str = '15011020699';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;