import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\D+\\s)|(\\d+\\s))+)?(([4-8])|([4-8](\\.|\\,)([0-9])+))((\\s?pol)|\"|''|\\x60|'|´|”)(?:.*)$";
final String string = "rom de as asd asd asd 444444 34234 6,5234234234polimeros (~ 64,3% relação tela-corpo)\n\n"
+ "(?:(?:(?:\\D+\\s)|(?:\\d+\\s))+)";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}