use strict;
my $str = 'rom de as asd asd asd 444444 34234 6,5234234234polimeros (~ 64,3% relação tela-corpo)
(?:(?:(?:\\D+\\s)|(?:\\d+\\s))+)';
my $regex = qr`^(((\D+\s)|(\d+\s))+)?(([4-8])|([4-8](\.|\,)([0-9])+))((\s?pol)|"|''|\x60|'|´|”)(?:.*)$`sip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}