re = /^(((\D+\s)|(\d+\s))+)?(([4-8])|([4-8](\.|\,)([0-9])+))((\s?pol)|"|''|\x60|'|´|”)(?:.*)$/i
str = 'rom de as asd asd asd 444444 34234 6,5234234234polimeros (~ 64,3% relação tela-corpo)
(?:(?:(?:\\D+\\s)|(?:\\d+\\s))+)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end