re = /(?<!\d)(?<!\d\.)(?:\d{1,3}(?:,\d{3})*|\d+)(?:\.\d{1,2})?(?!\.?\d)/m
str = '120,000.00
40,000
456,667
334532
123,223,333.34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end