#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+(?=\s+file1\b)"
Local $sString = "123123abc file2" & @CRLF & _
"274efcc4d8a0e8f61397be46bd4bfa37 file1" & @CRLF & _
"321 file1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")