const regex = /\w+(?=\s+file1\b)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(?=\\s+file1\\b)', '')
const str = `123123abc file2
274efcc4d8a0e8f61397be46bd4bfa37 file1
321 file1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}