package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ \(](\w{2})`)
var str = `(05C20 20F05)
(20F55 62Qxx)
(17B20 22E40 22F30 65Fxx)
(20-04 20H20)
(05C25)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}