use strict;
my $str = '(05C20 20F05)
(20F55 62Qxx)
(17B20 22E40 22F30 65Fxx)
(20-04 20H20)
(05C25)';
my $regex = qr/[ \(](\w{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}