re = /(?=(?'a'[\s\S]*))(?'b'X(?=\k'a'\z)|(?<=(?=x^|(?&b))[\s\S]))/
str = 'bla X bla'
# Print the match result
str.match(re) do |match|
puts match.to_s
end