#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^|\G)\d"
Local $sString = "1 12 end line " & @CRLF & _
"10 3 end line " & @CRLF & _
"50 444 end line " & @CRLF & _
"100 54 end line " & @CRLF & _
"1000 5 end line"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)