// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<br \/>([\w-]+):\s*(.+)").unwrap();
let string = "<br />admin-c: AFM3
<br />tech-c: AFM3
<br />billing-c: AFM3
<br />nserver: ns1.locaweb.com.br
<br />nsstat: 20190304 TIMEOUT
<br />nslastaa: 20190301
<br />nserver: ns2.locaweb.com.br
<br />nsstat: 20190304 AA
<br />nslastaa: 20190304";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}