using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\\]";
string substitution = @"";
string input = @"<li class=\""product-col\""><div class=\""product-inner\""><div class=\""product-image\""><a href=\""https:\/\/test.com\/\""><img width=\""300\"" height=\""300\"" src=\""https:\/\/test.com\/imgs\/uploads\/00894771000341_front-300x300.jpg\"" class=\""img-fluid\"" alt=\""\""></a></div>Test Product</div></li>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}