const regex = /[\\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\\]', 'g')
const str = `<li class=\\"product-col\\"><div class=\\"product-inner\\"><div class=\\"product-image\\"><a href=\\"https:\\/\\/test.com\\/\\"><img width=\\"300\\" height=\\"300\\" src=\\"https:\\/\\/test.com\\/imgs\\/uploads\\/00894771000341_front-300x300.jpg\\" class=\\"img-fluid\\" alt=\\"\\"></a></div>Test Product</div></li>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);