// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?Usi)"name">(.+)<.+"value">(.+)<"#).unwrap();
let string = "<h3></h3>
<dl class=\"data\">
<dt class=\"name\">Поле1</dt>
<dd class=\"value\">Поле1_1</dd>
<dt class=\"name\">Поле2</dt>
<dd class=\"value\">Поле2_2</dd>
</dl>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}