$re = '/^(?!\d{1,6}$)(?:(?:\+43|00?) ?)\d+(?:[ \/–-]\d+)*$/m';
$str = 'Allowed:
03852 4637
03852 463728
03852/4637
038524637
03852463728
03852/463728
004338524637
+4338524637
00433852463728
+433852463728
00433852/4637
+4303852/4637
00433852/463728
+433852/463728
01 23457
0123457
01/23457
0043123457
+43 662 8180-0
0662 8180-0
0662 81800
066281800
0662 8180
06628180
0043662 818
00436628180
+43662 8180
Not Allowed:
122
133
144
121
911
112
110';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);