$re = '/^(\(?\s?\d{2,3}\s?\)?)?\s?([789]\d{3})\s?-?(\d{4})$/';
$str = '(51) 9989-1245
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);