const regex = /(\d{6})\s(\d{1,}:\d{2}:\d{2})|\s*(.*)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{6})\\s(\\d{1,}:\\d{2}:\\d{2})|\\s*(.*)\\s*', 'gm')
const str = `190219 7:05:30 line3 success
line3 this is the 1st success process
line3 this process need 3sec
200219 9:10:10 line2 success
line2 this is the 1st success process
190219 7:05:30 line3 success
line3 this is the 1st success process
line3 this process need 3sec
200219 9:10:10 line2 success
line2 this is the 1st success process
200219 9:10:10 line2 success
line2 this is the 1st success process
line2 this is the 1st success process
line2 this is the 1st success process
line2 this is the 1st success process
line2 this is the 1st success process
line2 this is the 1st success process`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}