use strict;
my $str = '190219 7:05:30 line3 success
line3 this is the 1st success process
line3 this process need 3sec
200219 9:10:10 line2 success
line2 this is the 1st success process
190219 7:05:30 line3 success
line3 this is the 1st success process
line3 this process need 3sec
200219 9:10:10 line2 success
line2 this is the 1st success process
200219 9:10:10 line2 success
line2 this is the 1st success process
line2 this is the 1st success process
line2 this is the 1st success process
line2 this is the 1st success process
line2 this is the 1st success process
line2 this is the 1st success process';
my $regex = qr/(\d{6})\s(\d{1,}:\d{2}:\d{2})|\s*(.*)\s*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}