// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/(?:(?:[\w\d-]\/?)*[A-Za-z0-9])$").unwrap();
let string = "/path
/valid/path
/this/regex/uses/A-Za-z0-9-_/and/should/end/with/A-Za-z0-9
invalid/path
another/invalid/path/
/this/is/also/invalid/
/whoops//ies
//not/even/a/valid/path";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}