$re = '/[^\p{L}\p{N}]+/m';
$str = 'J&öfá44';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;