#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<type>(?:ci-|cloud-)?[^-]+)[_-](?<version>\d+\.\d+\.\d+)(?<alpha>[-+]alpha)?(?:-(?<date>\d{8}))?[-+](?:(?<build>\d+).(?<builddate>\d{8}))?(?:[.-]?(?<sha>[A-Fa-f0-9]+(?:[.-]\d+)?))?(?:\.(?<arch>.+))?\.(?<fmt>.{3})"
Local $sString = "cloud-csm-6.4.13-20210927-89fa91ca.lnx.x86_64.zip" & @CRLF & _
"cams-7.2.4+4.20211216.zip" & @CRLF & _
"cams-7.2.4-alpha+4.20211216.zip" & @CRLF & _
"cca-6.4.23+753.20211216.193a0386-1.noarch.rpm" & @CRLF & _
"cca-6.4.23+alpha+753.20211216.193a0386-1.noarch.rpm" & @CRLF & _
"cca-6.4.23-alpha+753.20211216.193a0386.zip" & @CRLF & _
"cca_6.4.23+753.20211216.193a0386-1_all.deb" & @CRLF & _
"ci-j2ee-6.4.23+790.20211216.193a0386.zip" & @CRLF & _
"ci-j2ee-6.4.23-alpha+790.20211216.193a0386.zip" & @CRLF & _
"ci-server-6.4.23+790.20211216.193a0386.zip" & @CRLF & _
"ci-server-6.4.23-alpha+790.20211216.193a0386.zip" & @CRLF & _
"cloud-ci-7.1.15+90.20210119.46eef7d3-1.noarch.rpm" & @CRLF & _
"cloud-ci-7.2.4+247.20211216.eba3915b.noarch.zip" & @CRLF & _
"cloud-ci-7.2.4+alpha+247.20211216.eba3915b-1.noarch.RPM" & @CRLF & _
"cloud-ci-7.2.4-alpha+247.20211216.eba3915b.noarch.zip" & @CRLF & _
"cloud-cm-7.2.4+246.20211216.eba3915b-1.noarch.rpm" & @CRLF & _
"cloud-cm-7.2.4+246.20211216.eba3915b.noarch.zip" & @CRLF & _
"cloud-cm-7.2.4+alpha+246.20211216.eba3915b-1.noarch.rpm" & @CRLF & _
"cloud-cm-7.2.4-alpha+246.20211216.eba3915b.noarch.zip" & @CRLF & _
"cloud-csd-7.2.4+241.20211216.eba3915b-1.x86_64.rpm" & @CRLF & _
"cloud-csd-7.2.4+241.20211216.eba3915b.1-sym-x86_64.rpm" & @CRLF & _
"cloud-csd-7.2.4+241.20211216.eba3915b.lnx.x86_64.zip" & @CRLF & _
"cloud-csd-7.2.4+241.20211216.eba3915b.sym.lnx.x86_64.zip" & @CRLF & _
"cloud-csd-7.2.4+alpha+241.20211216.eba3915b-1.x86_64.rpm" & @CRLF & _
"cloud-csd-7.2.4+alpha+241.20211216.eba3915b.1-sym-x86_64.rpm" & @CRLF & _
"cloud-csd-7.2.4-alpha+241.20211216.eba3915b.lnx.x86_64.zip" & @CRLF & _
"cloud-csd-7.2.4-alpha+241.20211216.eba3915b.sym.lnx.x86_64.zip" & @CRLF & _
"cloud-csm-6.4.13-20210927-89fa91ca.lnx.x86_64.zip" & @CRLF & _
"cloud-csm-6.4.13-20210927-89fa91ca.win.x86.zip" & @CRLF & _
"cloud-cst-7.2.4+241.20211216.eba3915b-1.x86_64.rpm" & @CRLF & _
"cloud-cst-7.2.4+241.20211216.eba3915b.1-sym-x86_64.rpm" & @CRLF & _
"cloud-cst-7.2.4+241.20211216.eba3915b.lnx.x86_64.zip" & @CRLF & _
"cloud-cst-7.2.4+241.20211216.eba3915b.sym.lnx.x86_64.zip" & @CRLF & _
"cloud-cst-7.2.4+alpha+241.20211216.eba3915b-1.x86_64.rpm" & @CRLF & _
"cloud-cst-7.2.4+alpha+241.20211216.eba3915b.1-sym-x86_64.rpm" & @CRLF & _
"cloud-cst-7.2.4-alpha+241.20211216.eba3915b.lnx.x86_64.zip" & @CRLF & _
"cloud-cst-7.2.4-alpha+241.20211216.eba3915b.sym.lnx.x86_64.zip" & @CRLF & _
"cloud-parts-7.2.4-20211216.zip" & @CRLF & _
"cloud-parts-7.2.4-alpha-20211216.zip" & @CRLF & _
"cloud-xds-6.4.6-20211101-4b76a168.lnx.x86.zip" & @CRLF & _
"cloud-xds-6.4.6-20211101-4b76a168.win.x86.zip" & @CRLF & _
"cm-6.4.23+798.20211216.193a0386-1.noarch.rpm" & @CRLF & _
"cm-6.4.23+alpha+798.20211216.193a0386-1.noarch.rpm" & @CRLF & _
"cm-6.4.23-alpha+798.20211216.193a0386.zip" & @CRLF & _
"cm_6.4.23+798.20211216.193a0386-1_all.deb" & @CRLF & _
"cm_6.4.23+alpha+798.20211216.193a0386-1_all.deb" & @CRLF & _
"csm-6.4.13-20210927-89fa91ca.lnx.x86_64.tar" & @CRLF & _
"csm-6.4.13-20210927-89fa91ca.win.x86.zip" & @CRLF & _
"dbconfig-7.2.4+231.20211216.eba3915b.zip" & @CRLF & _
"dbconfig-7.2.4-alpha+231.20211216.eba3915b.zip" & @CRLF & _
"xds-6.4.6-20211101-4b76a168.lnx.x86.tar" & @CRLF & _
"xds-6.4.6-20211101-4b76a168.win.x86.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")