# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<type>(?:ci-|cloud-)?[^-]+)[_-](?<version>\d+\.\d+\.\d+)(?<alpha>[-+]alpha)?(?:-(?<date>\d{8}))?[-+](?:(?<build>\d+).(?<builddate>\d{8}))?(?:[.-]?(?<sha>[A-Fa-f0-9]+(?:[.-]\d+)?))?(?:\.(?<arch>.+))?\.(?<fmt>.{3})"
test_str = ("cloud-csm-6.4.13-20210927-89fa91ca.lnx.x86_64.zip\n"
"cams-7.2.4+4.20211216.zip\n"
"cams-7.2.4-alpha+4.20211216.zip\n"
"cca-6.4.23+753.20211216.193a0386-1.noarch.rpm\n"
"cca-6.4.23+alpha+753.20211216.193a0386-1.noarch.rpm\n"
"cca-6.4.23-alpha+753.20211216.193a0386.zip\n"
"cca_6.4.23+753.20211216.193a0386-1_all.deb\n"
"ci-j2ee-6.4.23+790.20211216.193a0386.zip\n"
"ci-j2ee-6.4.23-alpha+790.20211216.193a0386.zip\n"
"ci-server-6.4.23+790.20211216.193a0386.zip\n"
"ci-server-6.4.23-alpha+790.20211216.193a0386.zip\n"
"cloud-ci-7.1.15+90.20210119.46eef7d3-1.noarch.rpm\n"
"cloud-ci-7.2.4+247.20211216.eba3915b.noarch.zip\n"
"cloud-ci-7.2.4+alpha+247.20211216.eba3915b-1.noarch.RPM\n"
"cloud-ci-7.2.4-alpha+247.20211216.eba3915b.noarch.zip\n"
"cloud-cm-7.2.4+246.20211216.eba3915b-1.noarch.rpm\n"
"cloud-cm-7.2.4+246.20211216.eba3915b.noarch.zip\n"
"cloud-cm-7.2.4+alpha+246.20211216.eba3915b-1.noarch.rpm\n"
"cloud-cm-7.2.4-alpha+246.20211216.eba3915b.noarch.zip\n"
"cloud-csd-7.2.4+241.20211216.eba3915b-1.x86_64.rpm\n"
"cloud-csd-7.2.4+241.20211216.eba3915b.1-sym-x86_64.rpm\n"
"cloud-csd-7.2.4+241.20211216.eba3915b.lnx.x86_64.zip\n"
"cloud-csd-7.2.4+241.20211216.eba3915b.sym.lnx.x86_64.zip\n"
"cloud-csd-7.2.4+alpha+241.20211216.eba3915b-1.x86_64.rpm\n"
"cloud-csd-7.2.4+alpha+241.20211216.eba3915b.1-sym-x86_64.rpm\n"
"cloud-csd-7.2.4-alpha+241.20211216.eba3915b.lnx.x86_64.zip\n"
"cloud-csd-7.2.4-alpha+241.20211216.eba3915b.sym.lnx.x86_64.zip\n"
"cloud-csm-6.4.13-20210927-89fa91ca.lnx.x86_64.zip\n"
"cloud-csm-6.4.13-20210927-89fa91ca.win.x86.zip\n"
"cloud-cst-7.2.4+241.20211216.eba3915b-1.x86_64.rpm\n"
"cloud-cst-7.2.4+241.20211216.eba3915b.1-sym-x86_64.rpm\n"
"cloud-cst-7.2.4+241.20211216.eba3915b.lnx.x86_64.zip\n"
"cloud-cst-7.2.4+241.20211216.eba3915b.sym.lnx.x86_64.zip\n"
"cloud-cst-7.2.4+alpha+241.20211216.eba3915b-1.x86_64.rpm\n"
"cloud-cst-7.2.4+alpha+241.20211216.eba3915b.1-sym-x86_64.rpm\n"
"cloud-cst-7.2.4-alpha+241.20211216.eba3915b.lnx.x86_64.zip\n"
"cloud-cst-7.2.4-alpha+241.20211216.eba3915b.sym.lnx.x86_64.zip\n"
"cloud-parts-7.2.4-20211216.zip\n"
"cloud-parts-7.2.4-alpha-20211216.zip\n"
"cloud-xds-6.4.6-20211101-4b76a168.lnx.x86.zip\n"
"cloud-xds-6.4.6-20211101-4b76a168.win.x86.zip\n"
"cm-6.4.23+798.20211216.193a0386-1.noarch.rpm\n"
"cm-6.4.23+alpha+798.20211216.193a0386-1.noarch.rpm\n"
"cm-6.4.23-alpha+798.20211216.193a0386.zip\n"
"cm_6.4.23+798.20211216.193a0386-1_all.deb\n"
"cm_6.4.23+alpha+798.20211216.193a0386-1_all.deb\n"
"csm-6.4.13-20210927-89fa91ca.lnx.x86_64.tar\n"
"csm-6.4.13-20210927-89fa91ca.win.x86.zip\n"
"dbconfig-7.2.4+231.20211216.eba3915b.zip\n"
"dbconfig-7.2.4-alpha+231.20211216.eba3915b.zip\n"
"xds-6.4.6-20211101-4b76a168.lnx.x86.tar\n"
"xds-6.4.6-20211101-4b76a168.win.x86.zip")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.